Map is crashing consistently only after being vpked...

Mapping support for the Source engine.
User avatar
Posts: 314

Map is crashing consistently only after being vpked...

Post by insane3004 » 14 Mar 2017, 21:33

I have not had this issue before... and it is starting to drive me mad...

I have tried removing d80.vtx and sw.vtx files from the vpk... No Luck...
I have tried packing all the cotent in with VIDE... All it did was add another 200 mb to the file size, and NO Luck...
I have even tried removing all the materials and models from the vpk... Surprise surprise... NO LUCK...

I am at a complete loss... From what I have read it is related to custom models, but their solution is to use a program like VIDE to pack it into the bsp directly... Which did not help...

Does anyone know what the issue is or what it could be?... :cry:
"..."

The Neverglades
End of the Line
Haunting Grounds - Sawrunner

User avatar
Posts: 155

Re: Map is crashing consistently only after being vpked...

Post by greenhood » 15 Mar 2017, 04:01

At what point of loading map crashes?

This seems rather like something in the map is causing this. Try compiling the map with just brushes. Turn other stuff in Groups window.

User avatar
Posts: 314

Re: Map is crashing consistently only after being vpked...

Post by insane3004 » 15 Mar 2017, 09:40

But the problem is that when outside of the vpk... There are no issues, no crashes, and no signs of crashing after 40 minutes of still playing on it...

But I will have to see if it is a specific thing or not still... Since it was working perfectly fine at one point...
"..."

The Neverglades
End of the Line
Haunting Grounds - Sawrunner

User avatar
Posts: 155

Re: Map is crashing consistently only after being vpked...

Post by greenhood » 16 Mar 2017, 09:22

I never had problem like this, but if you use vpk.exe from bin folder to pack content, then maybe try checking files integrity.

User avatar
Posts: 314

Re: Map is crashing consistently only after being vpked...

Post by insane3004 » 16 Mar 2017, 15:50

I've already verified integrity...

The main problem is that it used to work fine... But apparently one of my lat updates broke it, and I have no idea what exactly it is I added that could have broke it so bad...

Been recompiling with various things disabled for four days now... and I am getting desperate... I don't want to go the nuclear option and just try and remake it as quickly as possible from scratch... But... So for it looks like it is quickly becoming my only option...
"..."

The Neverglades
End of the Line
Haunting Grounds - Sawrunner

User avatar
Posts: 314

Re: Map is crashing consistently only after being vpked...

Post by insane3004 » 16 Mar 2017, 17:09

I have tried all the following, and none have worked so far...
- Removing all d80.vtx and sw.vtx files from the vpk...
- Packing all content into the bsp using VIDE...
- Disabled areaportals and Occluders... (It is a wide open map, so I have alot of both)
- Removed all decals and overlays... (I had some missing decals, was worth a shot)
- Compiled with default lighting settings... (Since I use some custom ones in the expert compiler)
- Disabled all lights and turned off vrad...
- Disabling all models failed...
- Disabling all particles, sprites, and beam spotlights failed...
- Disabling all displacements failed...
- Disabled all ropes and cables failed...
- Disabled water failed...

BUT... When I ran with the director disabled... It didn't crashed... (Why I didn't do this first is beyond me... >~<)
So I finally know it is a problem related to the infected in some way... Ci limits, blood decals on something, ragdoll limits... I finally have a lead...
"..."

The Neverglades
End of the Line
Haunting Grounds - Sawrunner

User avatar
Posts: 155

Re: Map is crashing consistently only after being vpked...

Post by greenhood » 17 Mar 2017, 11:02

If its related to game director the maybe try rebuilding navigation mesh.


Return to Source SDK