Crashing out of L4D2 for no reason (runtime error)

Have an issue with the game? Request support here!
User avatar
Posts: 1

Post by Helio69 » 05 Aug 2012, 02:22

Hey guys, I think I'm getting the same problem as Mateoski. I've had the game from the start and this issue has been going on for the last 4 or 5 months. It's really the most annoying error I've ever encountered.

In my case, it usually happens in the finale of any given campaign when we start the event. (ex: dark carnival, I can turn the light switch on with no problems but as soon as I or someone else hits the button on the stage to set off the fireworks etc., I crash.)

It also occurs when I finish a campaign, during the brief outro of the survivors escaping in the vehicle right before the end stats/credits. I lowered the paged pool memory to medium/low, but that doesn't seem to fix anything.

In the back of my mind, I truly believe it has to do with corrupt "addons." I have over 30 addons installed in my folder that visually enhance my experience ingame. Not sure how I can test/fix this as this error does not happen every time I play. It's quite random actually... :/

User avatar
Posts: 111

Post by Sableagle » 05 Aug 2012, 04:20

Well, I got sick of it and took drastic action. I copied the entire Steam folder into a new folder ... and got blue-screened. Well, shit. Try again. Blue screen. Okay, so new folder and copy bits one at a time out of old folder into new one, then rename old folder FUBAR and new folder Steam ... and so far everything seems to be working except that I had to look up ways to enter a Windows product key manually, because the system lost its OS product key when I renamed the folders. Seriously. Still got kicked from a L4D server with "no Steam logon" but I wasn't the only one kicked so that may not have been me. Have to play some more and see whether I go back to black-screen CTDs and "please remove plug-ins before connecting to a VAC-secured server" or actually have this working now.

That VAC-secured thing wasn't just on trying to join or start a game. That was when I tried to rejoin the friend still playing a game from which I just crashed out. Disabling all plug-ins didn't fix it, either.

User avatar
Posts: 14

Re:

Post by crash2004 » 05 Aug 2012, 07:20

Sableagle wrote:Well, I got sick of it and took drastic action. I copied the entire Steam folder into a new folder ... and got blue-screened. Well, shit. Try again. Blue screen. Okay, so new folder and copy bits one at a time out of old folder into new one, then rename old folder FUBAR and new folder Steam ... and so far everything seems to be working except that I had to look up ways to enter a Windows product key manually, because the system lost its OS product key when I renamed the folders. Seriously. Still got kicked from a L4D server with "no Steam logon" but I wasn't the only one kicked so that may not have been me. Have to play some more and see whether I go back to black-screen CTDs and "please remove plug-ins before connecting to a VAC-secured server" or actually have this working now.

That VAC-secured thing wasn't just on trying to join or start a game. That was when I tried to rejoin the friend still playing a game from which I just crashed out. Disabling all plug-ins didn't fix it, either.

Are you running the game from it's shortcut or through steam? I'm asking because I had the same issue happen to me when I was using the shortcut. Try just launching it from steam instead if you are using the shortcut. Other than verifying game cache, I can't think of anything else that might help.

User avatar
Posts: 9

Post by dlind70 » 05 Aug 2012, 07:24

Problems with steam?. Run Steam's install and hit repair. I believe it's called steamInstall.msi (different for MAC)

User avatar
Posts: 111

Post by Sableagle » 05 Aug 2012, 10:57

I shall try both of those things. Thanks.

Just crashed to desktop again, just as a pipe-bomb went off in the bit between the alley and the alarm tower in The Parish part 2. Rather annoying as I was hosting the server because I got sick of the VAC thing and the easiest way round it is sv_consistency 0.

Edit to add, as it may be significant: I'd hosted that server for Swamp Fever and Hard Rain with no trouble, so that's the twelfth "part" in a row that it was running when it crashed. If I didn't have 8GB of RAM, I'd suspect a memory leak. City of Heroes used to slow down horribly in portals if I went too long without dropping to desktop ... on my old 1GB machine. This one hasn't had issues with it.

User avatar
Posts: 111

Post by Sableagle » 06 Aug 2012, 10:49

Tried launching from Steam window just now. Played Dead Center and The Passing, then crashed in the Tunnel of Love in Dark Carnival part 3, making it part ... umm ... 11 overall, I think. At least it's consistent.

User avatar
Posts: 661

Re: Crashing out of L4D2 for no reason (runtime error)

Post by CrazyRabbit » 08 Aug 2012, 05:48

I'm also getting the runtime error and I think it does have something to do with Sourcemod being installed. I run -insecure in the commandline and it only Runtime Errors after loading my map via Hammer.

I'm going to remove those things and see what happens.

User avatar
Posts: 111

Re:

Post by Sableagle » 18 Aug 2012, 05:24

StixsmasterHD wrote:YOU ALL ARE WRONG!

DISABLE SOURCEMOD!

Its SDKHOOKS is completely outdated. That is the whole reason why you are crashing with 0 error messages or anythang reporting back to you really at all.

I had this issue when I tried using that mod after Cold Stream update came out.


I did a "delete local contect" or whatever it's called on Source SDK, Source SDK base 2007 and Source SDK base 2006 (in that order, because it insisted), and revalidated, and I have just run The Parish, No Mercy and Crash Course on a local hosted server with no problems at all.

Thanks!

Interesting observation, as I left the mod in place: nobody likes playing with the Hunting Rifle Overbuff, but everybody loves having it on the team. Well, not on the bridge finale where you're better off with the AK or Tac Shotgun, but almost anywhere else.

PreviousNext

Return to Left 4 Dead 2 Tech Support